Ticket #2303 (new defect)

Opened 1 year ago

Last modified 1 year ago

Packages won't install from Synaptic on Hardy due to libicu36 dependency

Reported by: douglas Assigned to: fransman
Priority: normal Milestone: 1.4.0-Monrovia
Component: Packaging Version:
Severity: minor Keywords:
Cc:

Description (Last modified by douglas)

After a fresh build of Debian packages after [3339], Synaptic is still refusing to install them. Here is the message from apt-get:

Depends on libicu36 but it is not going to be installed.

I checked the etc/debian/control file, and there the option is written like this:

Build-Depends: 
     libicu34-dev | libicu36-dev | libicu-dev (>=3.4),

then a little further down it is:

Package: campcaster-station
Architecture: any
Depends: 
      libicu34 | libicu36 | libicu38,

and further it is:

Package: campcaster-studio
Architecture: any
Depends: 
      libicu34 | libicu36 | libicu38,

I'm pretty sure the problem is with the line requiring libicu34-dev or libicu36-dev, as libicu36-dev has libicu36 as one of its dependencies. I would suggest requiring the libicu-dev package and not specifying a version number.

Change History

05/22/08 14:53:25 changed by douglas

  • description changed.

05/22/08 16:10:46 changed by douglas

It may also be useful to note that I built the packages using Gutsy, but tried to install them on Hardy. The Campcaster Station package was the one that returns the error.

05/22/08 19:08:51 changed by fvanberckel

Found what goes wrong, we did the builds on a Gutsy system and putted these ones in the Hardy ´╗┐´╗┐repository. So installing these one depends on libicu36, that's what not available in Hardy.