Ticket #2215 (new defect)

Opened 2 years ago

Last modified 10 months ago

campcaster doesn't compile on opensuse 10.2

Reported by: guest Assigned to: anonymous
Priority: normal Milestone: 1.4.0-Monrovia
Component: Development Environment Version:
Severity: minor Keywords:
Cc:

Description

checking for glib-2.0 >= 2.2 gobject-2.0 gthread-2.0 gmodule-2.0... configure: error: GStreamer requires GLib 2.2 to compile.
make[1]: *** [tmp/all.stamp] Error 1
make[1]: Leaving directory `/home/andi/bin/campcaster-1.2.0/src/tools/gstreamer/gstreamer-0.8.12'
make: *** [tmp/tools_setup.stamp] Error 2

Change History

03/11/07 04:31:09 changed by guest

my installed packages:

andi@idiotologia:~> rpm -qa | grep ODBC unixODBC-devel-2.2.12-13 unixODBC-2.2.12-13 psqlODBC-08.01.0102-34 andi@idiotologia:~> rpm -qa | grep glib glibc-locale-2.5-25 glibc-2.5-25 taglib-1.4-47 glib-sharp2-2.8.3-33 dbus-1-glib-0.71-26 glib2-devel-2.12.9-1 glibc-devel-2.5-25 glibmm2-2.12.2-11 glibc-i18ndata-2.5-25 glib-1.2.10-627 dbus-1-glib-devel-0.71-26 glib2-2.12.9-1

03/11/07 11:00:35 changed by fgerlits

The pkg-config file in the glib2-devel package is in the non-standard location /opt/gnome/lib/pkgconfig. Check if it can be found by pkg-config:

$ pkg-config glib-2.0 --modversion

If this gives you a "No package 'glib-2.0' found" error, then this is the problem, and it can be fixed by modifying the pkg-config path:

$ export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/gnome/lib/pkgconfig

You'll probably want to put this export command in your .bashrc file (and .bash_profile, too, if it does not source .bashrc.)

If the pkg-config command above does not give an error, and just prints "2.12.9", then the problem is somewhere else.

08/17/08 16:39:32 changed by douglas

  • milestone changed from 1.3.0-Dakar to 1.4.0-Monrovia.